Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Kapsel Version Problem (Creating offline Mobile App using SAP Web IDE)

Hi,

Am using

Java jdk : 1.8.0_45

Apache-Ant: 1.9.6

Cordova: 5.1.1

Git: 2.6.1

Node: V0.10.40

SAP_HAT_local: 1.9.3

Android SDK: 5.1.1 (API 22)

Kapsel :3.9.9

SAP Store (SMP3.0 SDK SP09 PL06) Trial Version

When am trying to run HAT Tool am getting the Kapsel incompatibility error. Have already cross checked with the source code of

C:\SAP\MobileSDK3\KapselSDK\plugins\toolbar \plugin.xml

 

<?xml version="1.0" encoding="UTF-8"?>

-<plugin version="3.9.9" id="kapsel-plugin-toolbar" xmlns="http://apache.org/cordova/ns/plugins/1.0">

It is showing correct version only but still am getting the error. Please help me.

Thanks in Advance,

PoornaChand M.

<?x

Tags:
Former Member
replied

What is the result if you type kapsel -v in your command line/terminal?

If the result is a version < 3.9 you need to update the Kapsel command line interface by running the following two commands:

  • SDK_HOME/MobileSDK3/KapselSDK/cli>npm uninstall -g kapsel
  • SDK_HOME/MobileSDK3/KapselSDK/cli>npm install -g


Afterwards try running kapsel -v again. If it shows the right version now you can re-run the installer.

Kr,

Andreas

2 View this answer in context
Not what you were looking for? View more on this topic or Ask a question