Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Cant get OpenUI5 Tutorial to work on HCP Trial

Experts,

Seeking some basic guidance..

I am brushing up my experience on the HCP. I have created by Hana trial environment. Successfully deployed HANA XS applications but run into an issue while executing the tutorial included in the Demo Kit from the UI development toolkit for HMTL5.

I am having an issue executing step 4: XML views. I have created the App.view.xml file and inserted the MVC code snippets.

After having saved the files and I run the application as WebApp the screen turns blue but the intended 'Hello World' text (which worked in step 3) is no longer there.

The tutorial ends with the following note:

From this step onwards, it is necessary to run the app on a Web server. We structure the app with multiple files that are loaded from the local file system. Without a Web server, this is prevented by the browser due to security reasons.

Given that my code no longer works after having broken up the application int multiple files I suspect that this might be the problem.

Can someone help me in resolving this?

I don't know whether or not the HCP has a WebServer; if yes - where can I find it, if not - how do I make this work?

Thanks in advance for your help,

Tiest

Former Member
Former Member replied

Ok - found it myself. Issue was a result of having the folder view named with a capital V - after changing to lowercase web application renders properly...

-Tiest

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question