Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

java mapping stop to work

hello everybody,

recently a costomer proposed me a problem.

They have a XI 3.0 installation with some interfaces.

They typically use java mapping and ccBPM.

1 month ago one of these java mapping ( working since 2007 ) stopped to work . Only one!

It's a interface FTP (flat file ) to BAPI.

Unfortunatelly i didn't developed this interface and i don't have source code. I checked the file and it's identical. Nothing changed in format.

I tried to search information in Process monitor and i found this:

Also if i try to search something in trace file i found the same error:

MESSAGE ID: com.sap.aii.ibrun.server.mapping.rb_MappingRuntimeException.STREAM_TRANSFORMATION_EX

com.sap.aii.ibrun.server.mapping.MappingRuntimeException: Application mapping program it/elsag/xi/mapping/ricambi/RicambiTabTransformationDoppia2 throws a stream transformation exception: Write end dead

    at com.sap.aii.ibrun.server.mapping.JavaMapping.executeStep(JavaMapping.java:67)....

....

Root cause:

com.sap.aii.mapping.api.StreamTransformationException: Write end dead

    at it.elsag.xi.mapping.ricambi.RicambiTabTransformationDoppia2.execute(RicambiTabTransformationDoppia2.java:193)

    at com.sap.aii.ibrun.server.mapping.JavaMapping.executeStep(JavaMapping.java:64)

....

If i try the java mapping from ESR test tool, i don't have any error, but the result is empty.

Does anybody have a suggestion about this enigma?

thanks in advance

Alessandro

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question