Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Parameter Passing issue with CBTA Composite Script

Hello ,

We have a critical issue with Composite Script.

We create Composite script with 13 child script and complete all message parameter passing, some time it run successfully 1 or 2 time. But after that for few of the child script (from 10th step) parameter passing is disappeared.

Here is a case where message at step 9 Script Z_VF01_TEST1 using input parameter as a output of first script SO_NO. And for this Z_VF01_TEST1 out put generated as INV_NO. Upto this level there is no issue. But while executing 10th Script Z_VF02_1 which require input parameter as INV_NO, parameter from reference para disappeared.

We require urgent help for this issue.

The only change we are doing before execution is we are changing MIRO script’s ref. document no. which should be unique for each execution, so we require to change it manually before each execution

Regards,

Ashishkumar Banker

Tags:
Former Member
Former Member replied

Hello,

We had raised OSS for this issue. And Solution is like we were using Usage type "Exposed"  for the paramameter we want to pass in other script, this need to be replace by "blank". Usage type will auto set to local when we map output ( export) of this script as an import parameter of other script.

We are not facing any issue after this change.

Regards,

Ashish

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question