Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAPinst GUI Server could not be started on AIX

Hi Gurus, I am running SWPM on a QAS Server. I need to do a system copy, I download last version of SWPM. My operating system is AIX :

# oslevel -s

6100-04-03-1009

DB2 is my database.

I need run sapinst, but following error show:

# ./sapinst

[==============================] - extracting...  done!

SAPinst build information:

--------------------------

Version:       2015.08.0

Build:         1602494

Compile time:  Sep 18 2015 - 16:03:56

Make type:     optu

Codeline:      720-2_REL

Platform:      rs6000_64

Kernel build:  721, patch 419, changelist 1564913

SAP JRE build: 61.80.80

SAP JCo build: 3.0.13

Exe directory: /tmp/sapinst_exe.397446.1443826546

guiengine: 2015-10-02 18:29:00 Waiting for client connection (1)

The GUI could not be started because the environment variable DISPLAY is not set . Please make sure that this variable is defined correctly or  start the GUI on another host (for details please consult the installation guide)

Starting GUIServer using:

  SAPinst port         : pipe:5:8

  GUIServer port       : 21212

  GUI autostart        : on

  GUI mode             : normal

  command : /usr/java14_64/jre/bin/java -Xmx512M -Dsap.env.var.javahome=SA PINST_JRE_HOME -cp /tmp/sapinst_exe.397446.1443826546/JAR/instgui.jar SDTServer rootdir=//.sdtgui config=jar:sdtserver.xml guiport=21212 -nolock -srvarg=/SAPins                                                                                        tService/host=127.0.0.1 -srvarg=/SAPinstService/port=pipe:5:8 guistart=off

The SAPinst GUI Server could not be started.

Java has been started with the following command line:

-Xmx512M -Dsap.env.var.javahome=SAPINST_JRE_HOME -cp /tmp/sapinst_exe.397446.144 3826546/JAR/instgui.jar SDTServer rootdir=//.sdtgui config=jar:sdtserver.xml gui                                                                                        port=21212 -nolock -srvarg=/SAPinstService/host=127.0.0.1 -srvarg=/SAPinstServic e/port=pipe:5:8 guistart=off

Because “SAPinst GUI Server could not be started” I can not continue.

I have JRE installed and path environment.

JRE:

# java -version

java version "1.4.2"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)

Classic VM (build 1.4.2, J2RE 1.4.2 IBM AIX 5L for PowerPC (64 bit JVM) build ca ix64142-20090307 (SR13) (JIT enabled: jitc))

Export command in AIX:

# export

AUTHSTATE=compat

HOME=/

LANG=en_US

LC__FASTMSG=true

LIBPATH=/usr/sap/BEQ/SYS/exe/run

LOCPATH=/usr/lib/nls/loc

LOGIN=root

LOGNAME=root

MAIL=/usr/spool/mail/root

MAILMSG='[YOU HAVE NEW MAIL]'

NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat

ODMDIR=/etc/objrepos

PATH=/usr/bin:/etc:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin:/usr/java14_64/jre/bin:/usr/java5/bin

PWD=/tmp/SWPMAix2

SAPINST_JRE_HOME=/usr/java14_64/jre

SHELL=/usr/bin/ksh

SSH_CLIENT='10.2.1.19 53235 22'

SSH_CONNECTION='10.2.1.19 53235 192.168.1.48 22'

SSH_TTY=/dev/pts/0

TERM=xterm

TMPDIR=/tmp

TZ=America/Caracas

USER=root

I check: permissions of SWPM (all in 777), I check space (I have free space), I ran this media on another AIX Server and it is ok, fine, then I know my software (SWPM) is OK. I search /tmp/sapinst_exe.663714.1443818609 and try to locate any log, but nothing there is.

Any other suggestion?.

Regards,

Jose

Tags:
Former Member
Not what you were looking for? View more on this topic or Ask a question