Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Agents not determined by Role 175

Hi everyone, hope you can help me here.

I am implementing WF Template WS00200074 (in fact I made a copy of it, just in case).

Everything is fine, linkage has been done properly, when I create a notification, the event gets triggered and an instance is made.

But when it comes to step 18 (task TS00008318), agents are not determined.  For this purpose, there is a standard rule 175 (PM_TASK_ROLE).  I tested it separately and it seems to be working fine.  I executed the role from tcode PFAC and it does bring the proper responsible.  But that is not happening from the workflow perspective.

I checked the role in the task, and it seems that there is no binding from the result of the role.  Does anyone knows if I should bind that result to something from the workflow container?

(Sorry for the image in spanish, but I guess you are familiar with the binding window).

You can check bellow how the binding window looks like right now, and that is how it is in the standard workflow too.

Tags:
replied

Many thanks, Modak.

Although I changed it to General, nothing happened. 

There is a configuration that goes with this task that needs to be taken care.  You can access it both from the task itself (while checking agents) or from SPRO configuration pannel.

From there you need to state which are going to be the agents, either users, positions, and many other options. But as long as this task does not clearly state the agents (setting it to general is not enough), then nothing would happen.

Hope this helps others in the future

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question