Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Query structure remains the same

Hi All,

I have been searching around for quite some time now and have yet to find a solution to this.

Basically I have a and APD which loads data to a CRM system. Inside this APD, I have a query and a target node which is pointing to CRM. This APD is called in a process chain.

Now, there is a program which is a mass update program which executes the chain multiple times. What I have noticed is that in the APD, the number of records structure remains the same for all the loads eventhough it supposedly to vary in the number of records. This only happens when the APD is ran in 1 execution a few times through the program. I have checked my program all is well.

I was checking around if it was the query cache issue because it seems like it's keeping the query result structure somewhere and reusing it every time the APD is ran, therefore I tried to set the query cache to inactive and tried many other things as well. But it did not work.

Has anyone out there have experience the similar issue? or if you have any idea why is this happening? or even maybe how to clear the cache?

Your input are greatly appreciated!!!

Thank you.

Best regards,

Amanda Ho

Tags:
replied

Hi Suhas,

Regarding your advice above, I actually have a routine in between the query node and the CRM target node in the APD. I put a breakpoint there and there is this internal table which stores the query result data. Everytime the APD is run through the mass program loop, it breaks there and when I check the table in the debugger, the amount of records in those tables remains the same as the first load.


I cant explain why this happens but I finally found a work around.

Somehow when the process chain is executed in synchronous using RSPC_API_CHAIN_START. I experience this issue however, when I tried to run in without the synchronous 'X', it creates background job and this structure issue did not happen anymore.

Maybe there is something storing the query structure in the back end which I have yet to locate. Whether it is some kind of cache or sessions, I am not sure.

If you have any insight on this, I would love to hear it.

Thank you.

Best regards,

Amanda Ho

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question