Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAP PI 7.4 - Fault Message

Hi guys,

i have a problem with Fault Message Type in following synchronous scenario:

Request: SAP Proxy -> PI 7.4 -> SOAP

Response: SOAP -> PI 7.4 -> SAP Proxy

My Operation Mapping has filled request, response and error tab. Request and response has a added a xslt mapping after message mapping respectively in case of response before message map step. My SOAP Adapter has parameter "use no soap envelope" and "keep header" activated. In soap modul, parameter "XMBWS.NoSOAPIgnoreStatusCode" set to "true".

In case of error i receive Fault Message in message monitoring like:

<?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<soapenv:Body>

  <soapenv:Fault>

   <faultcode xmlns:ns1="http://xml.apache.org/axis/">ns1:Server</faultcode>

   <faultstring>unknown data</faultstring>

   <faultactor>http://xxx.com</faultactor>

   <detail>

    <FaultDetail>

     <ErrorCode>37</ErrorCode>

     <Severity>Error</Severity>

     <DetailedMessage>incorrect data</DetailedMessage>

    </FaultDetail>

   </detail>

  </soapenv:Fault>

</soapenv:Body>

</soapenv:Envelope>

Proxy is not capturing the error although try catch is correct.

Any ideas whats wrong?

Not what you were looking for? View more on this topic or Ask a question