Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error BPC 10.0: "Hierarchy **** does not exist in BPC"

Hi experts,

I am facing with an error during the import of hierarchy from standard infoobject 0COSTELMNT. I managed to import master data succesfuly with the first package /CPMB/IMPORT_IOBJ_MASTER.

I have read a lot of threads about my error, but it was not helpful for me.

When uploading second package /CPMB/IMPORT_IOBJ_HIER, it fails with the next log:

My BPC dimension is ZACCOUNT. It has two hierarchies into its structure. (PARENTH1 does not appear because I removed it and when I put it again, it generates automatically PARENTH2, instead PARENTH1)

I have the ZACCOUNT dimension processed.

This is my hierarchy in BW side. This 0COSTELMNT has 4 hierarchies, but i just want to use P001ALL.

I am using these transformation file and conversion file:

    

In NODENAME sheet of conversion file, i have:

*                                   js:%external%.toString().substring(4)

When I validate the transformation file shown above (before run the 2nd package) with the hierarchy infoobject 0COSTELMNT, I get a correct result.

The only node text P001ALL is into ZACCOUNT sheet as a member. It was imported with the first package.

When I run the package /CPMB/IMPORT_IOBJ_HIER, this is my set selection:

The hierarchies does not have versions.

I have tried differents ways to run the package of hierarchy. With overwrite, update, internal, external...all combinations. I get the same error always.

I also try to upload other hierarchy of 0COSTELMNT, but I get the same error message

I would appreciate any help of you.

Kind regards,

Manu

Tags:
replied

Hi Manuel,

In the transformation file you have to use line:

HIER_NAME=HIER_CLASE.xls

Please read: How to Import Master Data and Hierarchies into SAP BusinessObjects BPC 7.5 from SAP NetWeaver BW

Vadim

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question