Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAP Hana with Sensor network

Hello Everyone,

I am trying to connect different sensors and sensor networks to HCP. I have started with the blog ESP8266 and HCP Internet of Things by @Prashantha H J. Firstly, Thanks for his efforts. Secondly, I am able to create token and device id successfully and I am able to send data from Chrome plugin Advanced Rest Client. As I am Embedded Systems Developer, I am not able to understand completely about POST request and GET request.

My Questions are:

1. I am trying to send request through AT commands. Below is the command

AT+CIPSTART="TCP","iotmmss000944X510trial.hanatrial.ondemand.com",80

AT+CIPSEND=309

POST /com.sap.iotservices.mms/v1/api/http/data/feffb77c-ad07-4ab2-b70b-fe2b0c5705Xd HTTP/1.0\r\n

Host: iotmmss000944X510trial.hanatrial.ondemand.com\r\n

Content-Type: application/json;charset=utf-8\r\n

{"mode":"sync","messageType":"7a2f26b89f04c5fX5cff","messages":[{"value":"22", "timestamp":"201509030334"}]}

I get SEND OK from my device. But Nothing I can see from Server side. Can any one help me to identify the problem in command. what I am missing.

2. Is it possible to Use GET Command instead of POST command? I am not using any PHP files.

Finally, I would like to implement complete commands and requests in C only.

Thanks in advance.

Naveen

replied

Hello Naveen,

1. After sending the data and getting HTTP Ok, do you see your table T_IOT_<MESSAGE_TYPE_ID> in embedded MMS UI (Application Data tile on top left)?

2. No, GET is used for different purposes. MMS expects POST requests when sending the data.

Regards,

Anton

1 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question