Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

WARNING: No credentials available for .pse Create credentials in transaction STRUST or with the sapgenpse tool

Hello!

I´m facing a problem generating credential for a .pse file,, i´m trying to import certificates for Digital Invoice... implementing this sap note:

http://service.sap.com/sap/support/notes/1300880

pkcs8 -inform DER -in C:\netadmin\CSD_0_CTP060127HZ0.key -passin pass:caja060127 -outform PEM -out C:\netadmin\CSD_01.key.pem -passout pass:caja060127

openssl x509 -inform DER -in C:\netadmin\00001000000302715470.cer -outform PEM -out C:\netadmin\CATRAPECOCER.cer.pem

openssl x509 -inform DER -in C:\netadmin\AC-Sat1070.cer -outform PEM -out C:\netadmin\AC-Sat1070.cer.pem

openssl x509 -inform DER -in C:\netadmin\raizBM.cer -outform PEM -out C:\netadmin\raizBM.cer.pem

copy C:\netadmin\CSD_01.key.pem+C:\netadmin\CATRAPECOCER.cer.pem+C:\netadmin\AC-Sat1070.cer.pem+C:\netadmin\raizBM.cer.pem C:\netadmin\CSD_01_chain.pem

pkcs12 -in C:\netadmin\SAPMXDI_CATR_800.pse -passin pass:caja060127 -export -out C:\netadmin\CSD_01.p12 -name SAT -passout pass:caja060127

sapgenpse.exe import_p12 -p C:\netadmin\SAPMXDI_CATR_800.pse -x caja060127 -z caja060127 C:\netadmin\CSD_01.p12

Then i apply the credentials and everything seems to be  ok

But when i run the program ZSSF_TEST_PSE it says no credentials for the pse

Any Idea??

Thank You!!!

Tags:
replied

I solved it,,

if anyone has the same problem, the solution is:

you have to run the credentials using de user that runs under the application server

see note:

http://service.sap.com/sap/support/notes/800240

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question