Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

dialog box cannot be displayed in IAC iview

Dear,

We have created a service for an IAC iview for an abap transaction with ALV. When testing transaction using web gui, it works fine. However, when testing the transaction thru the service, some of the function like 'Sort Ascending', 'Sort Descending' in the ALV toolbar does not work. The problem is that the dialog box that should be displayed after clicking 'Sort Ascending' or 'Sort Descending' cannot be displayed.

There is no such problem when testing the same transaction using web gui.

Following is the GUI configuration defined for the service

~COOKIES0

~GENERATEDYNPRO

1

~PASSWORD

~POPUPS1
~STYLEdhtml
~TIMEOUT10
~TRANSACTIONZZZZZZ
~WEBTRANSACTIONTYPEEWT
~FLICKERFREE0
~DISCONNECTONCLOSE0
~NOHEADEROKCODE1
~WEBGUI1
~SINGLETRANSACTION1
~USERAGENTCHECK0
SAP-IEEmulateIE8
~NOSPLASH1
~WEBGUI_POPUPS2
~WEBGUI_SIMPLE_TOOLBAR32
~THEME99

Any idea what is going wrong.

Thanks,

Francis

replied

Hi Francis,

Please test the service with only:

~TRANSACTION    ZZZZZZ

~WEBGUI    1

SAP-IE    EmulateIE8

If it works, then add:

~WEBGUI_SIMPLE_TOOLBAR    32

~NOHEADEROKCODE    1

The parameters:

~WEBTRANSACTIONTYPE    EWT

~PASSWORD

~TIMEOUT    10

should not be used (deprecated ones).

There are more parameters in the list: I recommend reading about each one of them before using - you can have odd results mixing parameters.

Regards,

Cris

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question