Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

R/3 4.6C to EE6 Ehp7 CUUC upgrade

Hi Experts,

We are upgrading our R3 4.6c system to Ecc6 Ehp7 upgrade.

We are following below strategy

1.Upgraded OS to Windows 2008R2

2.Upgrade Oracle to 11.2.0.4 (as supported for upgrade purpose)

3.Running CUUC using SUM SP13

We are in preprocessing phase

MAIN_SHDINST/SUBMOD_SHDALIASCRE/SCEXEC_ALIAS!

Here we are getting error as

4EETQ399 1 [  dboci.c, 4937]: OCISessionBegin(con=0, svc=087642A0, srv=087676C0='DVM'): start session usr=119B5670='SAPR3SHD', rc=1017

4EETQ399 1 [  dboci.c, 4972]: OCIHandleFree(con=0, svc=087642A0): Free session hdl usr=119B5670

4EETQ399 1 [  dboci.c, 4772]: OCIServerDetach(stale2 con=0, svc=087642A0, srv=087676C0='DVM') successfully detached

4EETQ399 1 [  dboci.c, 4793]: OCIHandleFree(con=0, svc=087642A0): Server handle srv=087676C0 freed

4EETQ399 1 [  dboci.c, 4507]: OCIHandleFree(con=0): Service svc=087642A0 freed (i=1).

4EETQ399 0 [ dbsloci.c,16095]: CONNECT failed with SQL error '1017'


We Tried below notes and Steps


2067086 - ORA-01017 during SAP Upgrade

400241 - http://service.sap.com/sap/support/notes/400241

1617976 - Case sensitive logon with Oracle 11g

2067086 - ORA-01017 during SAP Upgrade

1904239 - SUM options to change parameters entered in INITPUT and INITSUBST phases

We also tried below password combination.

1. Reset password as SAP in capital, using SUM and BRtools

2. Reset password as sap in small, using SUM and BRtools

3. Reset password as SAP12345 8 characters long in capital, using SUM and BRtools

4. Tried creating OPS$ user as OPS$<SIDADM>

5. Tried creating OPS$ user as "OPS$<Hostnmae>\<SIDADM>

6. Also updating SAPR3SHD password using BRTOOL command

brconnect -u system/pass123 -f chpass -o SAPR3SHD -p SAP

But still it is nod reading User password.

I have attached the log files kindly have a look

Please provide with your expert Solution..

Thanks,

Aditya

SQLEXEAL.txt.zip (1410 B)
replied

Hi Experts,

Thanks for your reply.

I found the solution (work around).

The issue was.

We configured SSFS after extraction when SUM tool prompts.

The environment variables are

RSEC_SSFS_DATAPATH = G:\usr\sap\<SID>\sys\global\security\rsecssfs\data

RSEC_SSFS_KEYPATH = G:\usr\sap\<SID>\sys\global\security\rsecssfs\key.

When we tried to update SAPR3SHD password using BRtools it was getting updated at SSFS files located at \usr\sap\<SID>\sys\global\security\rsecssfs\data.

But in SUM there is always a copy of SSFS file, which is not getting updated by BRtools.

located at

Y:\SUM\SUM\abap\mem\rsecssfs\data

As BRtools was detecting files as per environment variable

  • Solution -

AS workaround we changed environment variable to

RSEC_SSFS_DATAPATH = Y:\SUM\SUM\abap\mem\rsecssfs\data

RSEC_SSFS_KEYPATH = Y:\SUM\SUM\abap\mem\rsecssfs\key


Run BRtools and updated password for SAPR3SHD which was reflected in SUM SSFS directory.

Note- Replacement of SSFS file won’t work.

Once the file updated we revert the environment variables.

This resolved our issue.

For Quality and Production system we configured SSFS before starting the upgrade.

If the content of

\usr\sap\<SID>\sys\global\security\rsecssfs

and

\SUM\SUM\abap\mem\rsecssfs

is the same then this standard setting should not cause any issue.

Hope this will helpful !

Thanks,

Aditya

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question