Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

CX_SY_FILE_OPEN_MODE Error while loading from AL11

Hi Friends,

I am facing with a strange issue. I am running a process chain which loads two CSV files(two info packages) into the same DSO. Data is getting loaded for one info package while the other one is failing and i get this error message "An exception with the type CX_SY_FILE_OPEN_MODE occurred, but was neither handled locally, nor declared in a RAISING clause".

Both the files were in the same folder in AL11, Initially thought that the error could be due to both Info packages trying to access the same folder hence second Info package is not able to read the CSV file. Now, I have changed the folder structure( Created two folders) one for each file. Tried running the process chain but still the same issue.

Upon investigation I came across a scenario, the file which is throwing error, i did a bit of digging I can see the content of the file directly in AL11 transaction. However, when i try to link the file in the info packageĀ  under extraction tab that takes me to AL11 and the file path and then the file.

When double click on t.CSV file I get two options 1. Disp.Cont 2.Copy file name. I can copy the file name no issue, but when i click on the display content i get the folowing message "Unable to display the contents of this file" (Remember i can see the contents of this file if i use AL11 transaction directly).

To test what i have done is I have copied the above file on to the local work station and ran the Info package and guess what it sucessfully loads. The issue is only while loading from the application server and where the contents cant be dispalyed via the Info Package (I have double checked with some other files and the result is consistent) i.e where we cannot display content the error message is same.

Can someone please suggest how to handle this?.

Your help is appreciated.

Regards

BN

replied

Hi Friends,

My issue is resolved. Its a simple but strange issue though.

In AL11 file path, the floder structure is like the following

"\\dunv-bw7-p2\sapmnt\BIP\DATA\Folder Name" and the file name.

In the infopakageĀ  under extraction tab when we select the filename, it is copied as below

"\\dunv-bw7-p2\sapmnt\BIP\DATA\Foldername\file.csv." Here when the file name is copied from AL11 spaces are removedfrom the folder name(If any).

Solution is simple just make sure that the folder name in the extract tab is same as that of AL11 folder Name. (I know its strange as we just copy the file location from AL11).

Thanks to all for your quick replies and help.

Regards

BN

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question