Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Could not load file or assembly 'file:///C:\Program Files (x86)\SAP ... win\dotnet1\crdb_adoplus.dll'

I have seen a few solutions for this problem, (i.e. 64 bit version of CrystalDecisions.CrystalReports.Engine.dll for CR13 SP 9 version) but I suspect they are for Windows Forms Applications. I'm writing User control libraries, and none of the solutions, which usually use modifications to the app.config file to fix it, work for me.

I hopefully uninstalled everything from SAP this morning and reinstalled CRforVS_13_0_5.exe. I'm still getting the error.

The 'dotnet1' folder does not exist on my system.

I'm using VB.NET (VS 2012 with Update 4,) SQL 2014 Developer for a back end, and operating in the Windows 7 pro (x64) environment. I've set all of my apps and referenced libraries I wrote to target the 64 bit platform, and to target .Net 4.5. When that didn't work I tried .Net 4.0.

All of my apps and reports were originally written in VB 2005 (.Net 2.0) and are converted when I first open the solutions in VB 2012.

I tried creating the missing folder (dotnet1), and copied the file referenced there only to get another message saying I was using a mixed mode application. Apparently something in my assembly was using .NET 2.0. I could not find it.

I have been chasing this problem all week but nothing I do works.

I would like to target 4.5, because we are moving everything into the cloud and the other app we use, Microsoft Dynamics NAV, I think uses that framework. But I am not that particular. I  have options in that regard. However, I do want it to be a 64 bit solution.

Any help or suggestions will be appreciated.

Tags:
replied

Hi Marshall,

The absolute ONLY reason you will ever get this error: Could not load file or assembly 'file:///C:\Program Files (x86)\SAP ... win\dotnet1\crdb_adoplus.dll'

Is because the ADO.NET driver requires legacy mode to work so it must have this in the start up section of your app.config file:

<startup useLegacyV2RuntimeActivationPolicy="true">

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>

</startup>

Framework is adjustable.

If you do that then possibly there is another dependency you are missing. Process Monitor may tell you what that may be... Look for Access Denied errors also, could be a registry issue....

I am curious if creating new test app like Ludek suggested works... Start from the basics and then start adding your dependencies....

Also, can you confirm this is what you see in Programs and Features, I am using a current build of SP 15, what you should see is 13.0.14.1720 for the versions:

Both Ludek and I have support Crystal for the same time as you. He's 19 years and I'm 18 years here...

Don

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question