Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Agentry Error - DecryptPasswordError in ATE

Hello Experts,

I have installed "Agentry_70.8.0_Test_Environment" on a Windows 7 machine and using Work Manager 6.2 deployed in SMP 3.0 SP07.

Its giving the Decrypt Password Error (screen shot below).

As mentioned in "DecryptPasswordError-Agentry 6.0 | SCN" and "SAP Work Manager 6.0", I have deleted files at location "C:\Users\MYUSER\AppData\Local\Temp" and "C:\Users\MYUSER\AppData\Local\SAP AG".

Also removed "dbdata" folder and log files from the ATE folder (all the remaining files are .exe, or .dll).

I have tried re-installing the ATE client (As an Administrator) and still getting the same error. Would appreciate if you could provide any additional places to be cleared out. Thanks in advance!!

Tags:
Former Member
replied

Amandeep,

Hi. In SAP Work Manager 3.0 SP07 for the Agentry Test Environment there are two things I can think off and they are:

1) 32 bit ATE is not supported in SMP 3.0 release. If you are using the standalone Agentry ATE to use the 64 bit instead. The 64 bit ATE is located in the Agentry Eclipse Editor.  Open Eclipse Agentry SMP 3.0 SP07 or higher. Go Windows -> Show View -> Others -> Agentry -> Test Environment. Then click Start Test Client.

See thread: Agentry Toolkit - 64-bit Only | SCN

2) The other one is that to make sure that you have copied and installed your smp_crt.cer in the directory of your ATE and double click on it to install it in the trusted root. Some version requires the smp_crt.cer to exist in the same directory of your Windows client (including the ATE).

This is also true for the Eclipse Editor (ATE) - you have to have the smp_crt.cer in the same root directory of your Eclipse + install it.

so in essence,if you have issues with item 1 because it is 32 bit ATE, then you may get a response from the support team that this is not supported.  If your issue is tied to the Agentry Eclipse Editor ATE (based on the WPF 64 bit technology) then that is supported.

3) There are others tied to the DecryptPassword error like: DecryptPasswordError

Hope this helps.

Mark Pe
SAP Platinum Support Engineer

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question