Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Start Routine is not getting displayed in transformation after TR is moved

Hello,

We already had transformation from DS to DSO in our DEV, QA & PROD systems and due to one requirement I have to add one simple start routine in this transformation.

After I added start routine in Dev I tested it and validated. I captured this Transformation & routine in TR. This TR shows Transformation & Routine in it. After I moved it to QA. I am unable to see Start routine in transformation & in RSTRAN's STARTROUTINE field in QA.

However, I can see it in RSAABAP & RSAROUT tables in QA.


I did this 2 times and each time TR is successful & checked in STMS but still Start Routine doesn't reflect in  respective Transformation in QA.

We are on BW 7.4


1. Written Start Routine in Dev.

 


2. Captured this Transformation in TR.

3. Moved above TR to QA (TR ended with warnings). But QA doesn't show Start Routine in respective Transformation.

Tried same steps 2 times again but no luck. Even tried to activate Transformation through RSDG_TRFN_ACTIVATE program but of no use.

Harshawardhan.

Tags:
Former Member
replied

Hi Harshawardhan

First use the program rstran_rout_rsfo_check in both systems (source and target of the transport). It can detect inconsistencies in regard to the routines. If the program shows inconsistencies use the repair option to repair the transformation and reactivate them.

When this is done a new transport request must be created which contains the consistent version of the transformation.

There are also some notes, which might be helpful:

1825991Transformation not updated after transport (RSDS400, RSDS401, RSBK260)
2191288Transformation runtime program created without routines or formulas in rare cas

br

Roland

1 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question