Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAP B1 DIAPI remote connection error: Database server type not supported

Hi Experts!

It did worked when I tried to work locally.

But I got an error: Database server type not supported when I tried to connect the SAP by DI-API remotely.

I'm using the SAP B1(9.0).


My SAP database was on "SQL1"(MS SQL 2012) and the license server was on "APP1".


And my client machine is "CLIENT1".


Here's a piece of C#  code I used to open the connection:

            Company oCompany = new Company();

            oCompany.Server = "SQL1";

            oCompany.CompanyDB = "companyXX";

            oCompany.DbServerType = BoDataServerTypes.dst_MSSQL2012;

            oCompany.DbUserName = "sa";

            oCompany.DbPassword = "password";

            oCompany.UseTrusted = false;

            oCompany.UserName = "manager";

            oCompany.Password = "manager";

            oCompany.LicenseServer = "APP1:30000";

            oCompany.Connect();

I did install the Native SQL Server Client 2012 on my client machine, using the correct SAPbobsCOM.dll

and I confirmed I have set the admin account in IIS (did the operations in this ticket Database server type not supported).

But I still got the error:Database server type not supported.

Could you please suggest what I can do to solve this error?

Thank you very much in advance!

Billy

Tags:
replied

Hi Billy,

Sorry for the delay, was travelling.

Issue with testing by connecting with the SSMS is to verify:

  1. That the native client and Tools are correctly installed on the client,
  2. That the communication is properly working with the server from the client.

This has exactly nothing to do with integration working thru a server.

Firewall: again, issue is to check that communication is properly working from the client to the server, not that that the server is working.

DI API: same answer: the fact that it works on the server, doesn't mean it works on the client. In particular depending on how the client is installaed, what I asked to check.

Regards,

Eric

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question