Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Number field in HANA DB (decimal 15.2 or Integer) used as a Measure is (automatically) converted to string

Hi colleagues,

I'm experiencing some problems related to modeling AV:

  1. In HANA DB table I have a few values (decimal) fields that I'm going to use in my Analytical View (AV) - > SHINE model, table SO.Item - >fields GROSSAMOUNT, NETAMOUNT,...
  2. I'm using them in my AV
  3. At the time of creation of AV, I define them as "measures"
  4. After I validate&activate the AV I want to test it (of course)
  5. I open the data preview for my view and all measures are of type "STRING"

see the pictures attached.

Do you have any idea what's wrong? Lang/locale? Other?

My HANA Studio version is 2.1.4

HANA db version is rev97

thank you & regards,

Blaž

Tags:
replied

Hi all,

the issues is solved.

I tested the behaviour at my colleagues HANA Studio with lower version and there it worked.

to sumarize:

  1. our HANA db version is rev97
  2. I installed HANA Studio rev100 -> didn't work
  3. I downgraded HANA Studio to rev97 -> it works fine

Thank you all for you time and suggestions.

Regards,

Blaž

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question