Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

ERP-C4C Integration / Material replication error: "Material ID missing"

Hey there,

I am doing some unit testing over my Material replication between ERP into C4C and I am facing a particular error when checking results on C4C Web Service Message Monitor as I am getting an error which says "Material ID missing".

The scenario is:

- I only transfer Materials from ERP into C4C,

- the ID of the Material in C4C should be the same as in ERP so I have defined the number ranges and, also, I have adjusted the mapping in PO (as explained in SAP C4C Integration: Customization to achieve the Product Internal ID same as SAP ECC Product ID)

For some reason, PO consultant is seeing that the new mapping is not being taken into account?

Find below a screenshot of how the new mapping looks like (take into account that mapping against ID is still there in addition to the new one):

Thanks and regards.

Alejandro.

Tags:
replied

Issue solved!

Solution: we did a small change into the Operation Mapping from Entreprise Builder in order to be able to reactivate the object and it worked...strange but it worked!

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question