Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

R3trans -d error

Hi,

I have done the OS/DB migration from HP UX 11.23 to win 200 Server and Oracle 10.2.0.2 to oracle 12c. Now system is perfectly working. DB is also up but even though I am getting 0012 error while running R3trans. here I am attaching the trans log for your reference.

4 ETW000 r3trans version 6.24 (release 721 - 14.10.14 - 20:14:08).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time   : 29.06.2015 - 13:35:42

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: r3trans -d

4 ETW000  trace at level 2 opened for a given file pointer

4 ETW000  [     dev trc,00000]  Mon Jun 29 13:35:42 2015                                                 102  0.000102

4 ETW000  [     dev trc,00000]  db_con_init called                                                        38  0.000140

4 ETW000  [     dev trc,00000]  set_use_ext_con_info(): ssfs will be used to get connect information

4 ETW000                                                                                                  63  0.000203

4 ETW000  [     dev trc,00000]  determine_block_commit: no con_hdl found as blocked for con_name = R/3

4 ETW000                                                                                                  28  0.000231

4 ETW000  [     dev trc,00000]  create_con (con_name=R/3)                                                 21  0.000252

4 ETW000  [     dev trc,00000]  Loading DB library 'dboraslib.dll' ...                                    54  0.000306

4 ETW000  [     dev trc,00000]  DlLoadLib success: LoadLibrary("dboraslib.dll"), hdl 0, addr 000007FEEC170000

4 ETW000                                                                                                1075  0.001381

4 ETW000  [     dev trc,00000]      using "E:\usr\sap\ECD\SYS\exe\uc\NTAMD64\dboraslib.dll"               20  0.001401

4 ETW000  [     dev trc,00000]  Library 'dboraslib.dll' loaded                                            23  0.001424

4 ETW000  [     dev trc,00000]  function DbSlExpFuns loaded from library dboraslib.dll                    25  0.001449

4 ETW000  [     dev trc,00000]  Version of 'dboraslib.dll' is "721.02", patchlevel (0.419)               138  0.001587

4 ETW000  [     dev trc,00000]  function dsql_db_init loaded from library dboraslib.dll                   21  0.001608

4 ETW000  [     dev trc,00000]  function dbdd_exp_funs loaded from library dboraslib.dll                  41  0.001649

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=47=DBSL_CMD_IMP_FUNS_SET) -> changed=30, tagset=1

4 ETW000                                                                                                 175  0.001824

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=39=DBSL_CMD_SET_SINGLETASK)                     25  0.001849

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=10=DBSL_CMD_DBCA_PTR_GET)                       22  0.001871

4 ETW000  [     dev trc,00000]  New connection 0 created                                                  18  0.001889

4 ETW000  [     dev trc,00000]  00: name=R/3, con_id=-000000001, state=DISCONNECTED, tx=NO , bc=NO , hc=NO , perm=YES, reco=NO , info=NO ,

4 ETW000                            timeout=000, con_max=255, con_opt=255, occ=NO , prog=                 37  0.001926

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=10=DBSL_CMD_DBCA_PTR_GET)                       26  0.001952

4 ETW000  [     dev trc,00000]  db_con_connect (con_name=R/3)                                             18  0.001970

4 ETW000  [     dev trc,00000]  determine_block_commit: no con_hdl found as blocked for con_name = R/3

4 ETW000                                                                                                  25  0.001995

4 ETW000  [     dev trc,00000]  find_con_by_name found the following connection:                          19  0.002014

4 ETW000  [     dev trc,00000]  00: name=R/3, con_id=000000000, state=DISCONNECTED, tx=NO , bc=NO , hc=NO , perm=YES, reco=NO , info=NO ,

4 ETW000                            timeout=000, con_max=255, con_opt=255, occ=NO , prog=                 34  0.002048

4 ETW000  [     dev trc,00000]  read_con_info_ssfs(): reading connect info for connection R/3             18  0.002066

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=74=DBSL_CMD_CON_INFO_EXT_SUPPORT) -> rc=0=DBSL_ERR_OK, con_vers=0

4 ETW000                                                                                                 119  0.002185

4 ETW000  [     dev trc,00000]  con_info_ext_support(): DBSL supports extended connect protocol           38  0.002223

4 ETW000                          ==> connect info for default DB will be read from ssfs

4 ETW000  [     dev trc,00000]  con_info_ext_support(): auth/shadow_upgrade = undefined                   38  0.002261

4 ETW000                         ==> Using default key set to get connect info from ssfs

4 ETW000  [     dev trc,00000]  read_ssfs_record(): register callback ssfs_dbi_trace and max level 2

4 ETW000                                                                                                  33  0.002294

4 ETW000  [     dev trc,00000]  RSecSSFs: Entering function "RSecSSFsGetRecord" [rsecssfs.c 872]          48  0.002342

4 ETW000  [dbcon.c     ,00000]  *** ERROR => RSecSSFs: SAP-Profile is not used; in this case, all three environment parameters SAPSYSTEMNAME, RSEC_SSFS_DATAPATH and RSEC_SSFS_KEYPATH must exist and have non-initial values [rsecssfs.c 4630]

4 ETW000                                                                                                 142  0.002484

4 ETW000  [dbcon.c     ,00000]  *** ERROR => RSecSSFs: SAP-Profile is not used; in this case, all three environment parameters SAPSYSTEMNAME, RSEC_SSFS_DATAPATH and RSEC_SSFS_KEYPATH must exist and have non-initial values [rsecssfs.c 4630]

4 ETW000                                                                                                 146  0.002630

4 ETW000  [     dev trc,00000]  RSecSSFs: Exiting function "RSecSSFsGetRecord" with return code -2 (message: SAP-Profile is not used; in this case, all three environment parameters SAPSYSTEMNAME, RSEC_SSFS_DATAPATH and RSEC_SSFS_KEYPATH must exist and have non-initial values) [rsecssfs.c 940]

4 ETW000                                                                                                  77  0.002707

4 ETW000  [dbcon.c     ,00000]  *** ERROR => read_ssfs_record(): RSecSSFsGetRecord(DB_CONNECT/DEFAULT_DB_USER)=-2 : SAP-Profile is not used; in this case, all three environment parameters SAPSYSTEMNAME, RSEC_SSFS_DATAPATH and RSEC_SSFS_KEYPATH must exist and have non-initial values

4 ETW000                                                                                                  56  0.002763

4 ETW000  [     dev trc,00000]  read_ssfs_record(): deregister callback ssfs_dbi_trace                    21  0.002784

4 ETW000  [dbcon.c     ,00000]  *** ERROR => Connect to R/3 failed. USERID and/or PASSWD could not be retrieved from SSFS

4 ETW000                                                                                                  35  0.002819

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=41=DBSL_CMD_RELINFO_GET)                        30  0.002849

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=14=DBSL_CMD_VERSION_GET)                        22  0.002871

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=50=DBSL_CMD_GET_PATCH_INFO)                     23  0.002894

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=13=DBSL_CMD_VENDOR_NAME_GET)                    57  0.002951

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=52=DBSL_CMD_GET_DBLIB_VERSION)                  22  0.002973

4 ETW000  [     dev trc,00000]                 -> 'OCI_10201_SHARE, '                                     23  0.002996

2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'ECD'"

I have already set the RSEC_SSFS_DATAPATH, RSEC_SSFS_KEYPATH in RZ10 and ennviprnment variables but still facing the issue.

Regards

Nitin

Former Member
Former Member replied

Hi Nitin,

Is the key files present in ssfs folders and also you can try to recreate the same files again. rename the old files and try it again with sidadm user. We had simmilar issue and by recreating the files it worked it was a hp-ux enviorment though. So request you to follow the link provided by divyanshu to re-create the files again.

Regards,

Ram

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question