Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

"Logon failed" when using the CrystalActiveXReportViewer control in CRXI

I have a VB6 application which runs fine on my development machine.

When I install it on a PC running Windows 7 Home Premium, I get a

"Logon failed." error message.  The app uses the CrystalActiveXReportViewer

control.

The code on my main form opens an Access 1997 database and populates

an ADO recordset.  Then it show another form containing the Report Viewer

control.

The code in the load event of the from containing the control follows:

Set repVendorMasterList = New dsrVendorMasterListNew

repVendorMasterList.Database.SetDataSource rsReport

repVendorMasterList.PaperOrientation = crPortrait

CRViewer1.ReportSource = repVendorMasterList

CRViewer1.ViewReport

I suspect the "Logon failed." message is generated when the SetDataSource

property is set.

The only references I have selected in the VB project (in addition to the

default selections) are:

Crystal ActiveX Report Viewer Library 11.5

Crystal Reports ActiveX Designer Run Time Library 11.5

Microsoft ActiveX Data Objects 2.7 Library

My Setup program was built using InstallShield Express 2015.  I selected the

following merge modules:

CR115_rdc_license

CR115_rdc_reportengine

CR115_rdc_runtime

What do I need to do the fix this issue?

replied

Thank you so much for replying to my question.  I really appreciate it.

First off, I actually am using Crystal Reports XI, version 11.5.

I discovered I had two problems.

One problem was the designer I was using was from Crystal Reports version 11, not

version 11.5.  When I originally built my project I included a form that came from

another VB6 project.  That form contained a designer from Crystal Reports version 11. 

I removed the designer that was built using version 11 and built a new designer using

Crystal Reports version 11.5.


Also, the following statement didn't work because the actual name of the viewer on my

form containing the viewer control wasn't "CRViewer1" but "CrystalActiveXReportViewer1".

I didn't discover this mistake until I corrected the first problem.


I guess if I want to use designers from CR XI version 11 I will actually have to save them

as RPT files and then import them into CR XI version 11.5.


Thanks again for your prompt reply!

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question