Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Alerts not triggered for TRA scenarios


Hi,

We are currently testing the alert management scenario but somehow its not working.Somehow none of the FM's-/SAPTRX/CREATE_ALERT

are getting triggered both for event check & alert create.The logs in SLG1 shows that the activities are performed.But in simulate mode the debug mode does not gets triggered.

Below enclosed are the settings done:

a) Define alert categories-and create or select the existing classification.


Fill up the details of properties tab page and also check if container tab page is filled up properly with data element and ABAP dict.Also fill up the message details under long and short text tab page.



b) Then choose Event Management-Reactions to Event Messages- Define Alert Framework Connection- Define Alert Framework Integration to SAP Event Management.

Here specify the proper communication method which is internet email address and specify the communication data which is an EM parameter.Also activity parameter ID needs to be there.

c) To trigger and send an alert message, you must call the Alert framework. To do so, add the activity ALERT_CREATE to the corresponding rule set and reference the activity parameter ID with the parameter Activity. ID  that you created in Customizing activity Define Alert Framework Integration to SAP Event Management.

d) establish the connection to your communication system in Customizing for SAP Event Management under- Reactions to Event Messages  Define Alert Framework Connection-  Define SAPconnect Administration  .

e) Define the RFC connection from SAP Event Management to the Alert Framework in Customizing for SAP Event Management under   Reactions to Event Messages  Define Alert Framework Connection - Define RFC Connection to Central Alert Server  .

replied

Could you activate log for Alert Framework in ALRTCATDEF

-> Settings -> Configuration -> Write log

and also enter here a user that has in SU01 an email Address assigned.

Afterwards run your process again and post the SLG1 log for Object: Alert here.

Best regards,

Steffen

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question