Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

'Inconsistencies between effective context and configuration' problem after transporting in Prod

Hello!

I'm having an issue in the WEB UI.

I have added search criterias and result values to Leads in CRM. I've added the fields in CRMST_QUERY_LEA_BTIL and CRMST_QUERY_R_LEA_BTIL structures, i've used some customizing to make the fields appear as available fieds in the component BT108S_LEA and define their description text, then used the configuration tool to display the new fields in the web ui. I also implemented the corresponding Badis so that the new search criterias and result values are used/filled during the search. Everything worked fine in the Dev environement.

Same thing after transporting everything into the Quality environement, it worked fine.

But after transporting the orders to Prod, I'm having some issues. I get the following warning message when I check the Web UI Configuration tool : 'There are inconsistencies between effective context and configuration'. I've checked everything, many times, and everything has been transported correctly to Prod.

When I acces the Leads search Page in Prod, many of the criterias/fields are missing, and the others are displayed with the text associated to their respective data element, instead of the description text given during customizing. I've checked the customizing in Prod, and it is the same than Dev. I've also checked the Web UI configuration and it is the same too. The structures and the Badis are the same too, and the search is working for the remaining fields in the Leads search Page.

I also tried transporting the orders again, and i tried to redo the work, and none of it worked.

Can anyone please help me? I've run out of options.

Regards,

Yassine.

Former Member
replied

Please try to refresh the shared memory and see, transaction shmm, shma.

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question