Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

DR_admin user and <SID>_maint user are missing after installing SAP replication server software on Standby ASE DB

Hi Everyone,

We are trying to setup DR using sybase replication server. We are facing issue when installing SRS on Primary DB.

Can you please let us know if anyone had encountered similar issue/have a solution?

We have done the following so far:

1. Install ECC6 EHP6 using ASE 15.7.0.132 (distributed installation, CI and ASCS on Host1, DB on Host3)

2. Install Empty Database on Host2 (which should server the purpose of standby DB)

3. Install SAP Replication Server Software on Host2 (by unchecking Configure replication environment in the SAP Installer)

All the above mentioned activities are successfully completed.

Now we are in the phase to Install SAP Replication Server Software on Host3 (Primary DB) but SAP Installer throws an error after input for Replication System Parameters is provided.

Error:

On further analysis, we observed that DR_admin and SID_maint users are missing in standbyDB (Host2) where empty DB was created followed by SRS installation (by unchecking Configure replication environment in the SAP Installer)

But the SAP Installer for SAP Replication Server mentions that DR Administration user is successfully created on Host2 (standby DB).

Is this a bug? Installer mentions that DR Administration user is created where as sp_displaylogin shows that 'dr_admin' user does not exist.

thanks

Sai

Tags:
Former Member
Former Member replied

Hi Cris,

The issue is resolved.

During the installation of SRS on Stand by DB, I have provided the path of profile directory of Primary DB. As a result of this, DR_admin user for Standby DB got created in Primary DB (I know it sounds crazy).

I have uninstalled the SRS on Standby DB and reinstalled SRS using the path of profile directory on Standby DB (Only Empty DB is installed at the time when SRS is installed on Standby DB).

I am able to successfully login using DR_admin on to Standby DB. I have resumed the SRS installation on Primary DB and I no longer get the issue with DR_admin.

Hope this info. will be useful for someone who might encounter similar issue.

thanks

Sai

1 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question