Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

webi report error "unable to get the first page of the current report"

Hi Experts,

I have an issue with a Webi report which was working as expected sometime ago but now it does not work with the error as below-

  • When I click on the report to open it, it throws a prompt saying 'This document does not contain any reports (Error: INF).'.
  • When I click again to modify the report, it terminates with error 'unable to get the first page of the current report. Please check the validity of your report (ERR WIJ 20003)'. I have gone through a number of threads and unchecked the ‘enable query stripping’ and have removed some filters and tried to save the report, but it does not let me save. It throws the  'saveDocumentToCorporate' API. (ERR_WIS_30270).


We are on SAP BusinessObjects BI Platform 4.1 Support Pack 2 and I am using the admin id to access this report.

Could you please guide as to how I should proceed. Appreciate any help I could get on this.

Thanks,

AM

error.jpg (77597 B)
Tags:
Former Member
Former Member replied

Hi All,

I raised this issue SAP and turns out we need a SP level upgrade to tackle this. The latest versions of BO handle this and these symptoms are not reproducible there. The corrupted reports worked on the SAP BusinessObjects BI Platform 4.1 Support Pack 5.

The issue could also be caused by a duplicate Filter which inconsistency is not handled correctly since BI 4.0 SP06: (See SAP KB: 1961845).

I am still not sure though if there is a way to recover the corrupted webi reports.

Thanks for your inputs on this.


Regards,

AM

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question