Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Webdynpro View Layout error after configuring mandatory settings in SAP and Host

Dear Techies,

                     I'm running EHP7 on Windows Server 2008 R2 with Oracle DB on a Virtual machine. I have an network adaptor in my system for accessing internet with automatic IP and DNS configurations and created Loopback adaptor and configured manual ip address for accessing SAP system, configured SAP GUI using the same ip address as in loopback adaptor.

Later I created a domain in Windows Server 2008 and restarted my system and logged in to domain controller Administrator user. I have made necessary entries in windows host file with my full computer name, below I've listed the host file entry.

Windows Host File

I have made necessary entries on RZ10 Default profile on my server, listing out the profile settings below. Marked in blue are the parameters I created.


#.*                                                                                                                            *

#.*       Default profile DEFAULT                                                                                              *

#.*                                                                                                                            *

#.*       Version                 = 000025                                                                                     *

#.*       Generated by user = SAP*                                                                                             *

#.*       Generated on = 07.05.2015 , 19:16:26                                                                                 *

#.*                                                                                                                            *



j2ee/dbtype = ora

j2ee/dbname = AMG

j2ee/dbhost = SAPECC6EHP7



system/type = ABAP



rsdb/ssfs_connect = 1

rdisp/mshost = SAPECC6EHP7

rdisp/msserv = sapmsAMG

rdisp/msserv_internal = 3901

login/accept_sso2_ticket = 1

login/create_sso2_ticket = 2

login/ticket_expiration_time = 60

enque/process_location = REMOTESA

enque/serverhost = SAPECC6EHP7

enque/serverinst = 01

is/HTTP/show_detailed_errors = FALSE

icf/user_recheck = 1

icm/HTTP/ASJava/disable_url_session_tracking = TRUE

icm/host_name_full =

service/protectedwebmethods = SDEFAULT

rsec/ssfs_datapath = $(DIR_GLOBAL)$(DIR_SEP)security$(DIR_SEP)rsecssfs$(DIR_SEP)data

rsec/ssfs_keypath = $(DIR_GLOBAL)$(DIR_SEP)security$(DIR_SEP)rsecssfs$(DIR_SEP)key

gw/acl_mode = 1

login/password_downwards_compatibility = 0

login/system_client = 800

rdisp/TRACE = 1

Activated the profiles in my system and restarted the application server on SAP MMC, I logged into the system and check the Web Dynpro view layout, I get the same error saying "This program cannot display the webpage "

I checked the URL of the Web Dynpro application, listing out the URL below.

How to resolve this issue ? Are there any more configurations that needs to be done for Web Dynpro and DNS (not reachable) ?

Kindly list out the steps to be done.

Thanks in Advance.

Not what you were looking for? View more on this topic or Ask a question