Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Password file required for commandline job execution?

Hi all,

It appears that I am unable to execute batch jobs through the commandline without using the password file option.

I have correctly generate the execution script files through the Data Services Management Console. I have reviewed the scripts and they all appear well formed with the correct parameters.

But when I generate the script and unselect the "Use Password File" option, I keep getting this error when trying to launch the job from the commandline:

( 04_24_2015 09:54:58 (7696): No DS Local Repositories Registred in CMS

( 04_24_2015 09:54:58 (7696): *** RWJL_EXIT called.

( 04_24_2015 09:54:58 (7696): *** ERROR: RWJobLauncher failed to connect to CMS. (BODI-1250220) [/code]

When I tick the "Use Password File" option - it all works fine. However, I have a need to use the "old style" approach where there was no such thing as a password file.

So the above errors happens on our SAP DS 4.2 SP4 test system that runs on Microsoft Windows and uses SQL Server 2012 as repository + CMS (IPS) database.

When I try this on the actual SAP DS 4.2 SP4 system that runs on Red Hat Linux Enterprise and uses Oracle 11gR2 as repository + CMS (IPS) database, I get this error:

04-17-2015 14:22:51     Specified CMS authentication is not available.

04-17-2015 14:22:51     ERROR(CCMSLogonManager::InitializeSession)

04-17-2015 14:22:51     RWJobLauncher failed to connect to CMS.

04-17-2015 14:22:51     RWJobLauncher return code: 180011

On our older versions of Data Integrator (down to 11.5.3) the commandline execution on both Windows and Linux always worked fine and never required the use for a password file (I don't think this option even existed back then).

I have a requirement to make this work WITHOUT the password file. I have consulted the technical manuals but I cannot find anything that indicates this shouldn't work. I also cannot find any SAP Note that indicates that there is a problem here.

Am I missing something here? Has anyone else ran into the same issue and errors - and if so,  could you please share how you resolved this?  At this stage, my next port of call is to raise a SAP Support incident but I want to make sure I have tried all options first before I reach out to support.

Not what you were looking for? View more on this topic or Ask a question