Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

CBTA Recording does not start

Hello all,

I tried to get CBTA working.

And alhough I did the setup like in the wiki documet ( also including applying actual notes) and everything is green in the Solman Setup, I cannot start a recording.

I also switched on the scripting options to notify on attaching or opening a connection.

The behavior is like this:

  1. I start the recording
  2. 2 times gui pop up "A script is trying to attach to the GUI".
  3. The test creation wizard opens
    1. pressing next
  4. gui pop up "A script is opening a connectino to system: " (no system named)
  5. Action on SAP Logon
    1. No display of any system anymore in saplogon
    2. frame color changes
  6. Test creation wizard:
    1. Sole message "Unable to start recording See log"
    2. Cancel is the only active option.

My user in Solman and technical user in SUT do not show an authorization problem.

ST05 trace in SUT for technical users shows logs, so it is acessing the SUT ( technical user is a service user).

Function TAO_CHECK_AUTHORIZATION on SUT does not report missing authorizations for requested for role SAP_TST_AGENT_RFC, SAP_WDA_TST_RFC (as we are using a copies of roles).

Version of wizard 3.0.4.3

Sap Logon version

MAIN MODULE INFORMATION:

   saplogon.exe

   SAP Logon for Windows

   740 Final Release

   7400.1.0.1093

   1524627

SYSTEM INFORMATION:

   Operating system: Windows 8.1 Enterprise 6.2 (9200)

ST-A/PI release from CVERS 01R_731

Do you have an idea?

My assuption is that the setup is somehow wrong in a way that the recording script does not know where to log on (system is empty in popup).

But from which field is this information taken? From the SUT Systems in the CBTA? Or does the naming of the systems in SAPLOGON has to be similar? (The system id in saplogon is unique for the SUT). Or is the Saplogon versin wrong?

So I'm going to have a frustrated lunch.

Jürgen

replied

Looking at the logs in C:\Users\<myuser>\AppData\Roaming\SAP\CBTA\logs\CBTA.DefaultDomain.log i found out that there is a problem with logon, as I have to use a sap router string. This leads to sap note "2007184:SAP Router Support in CBTA" that requires an entry in saplogon for the cbta rfc destination. But it still does not work, so I need some more debugging time.

And i also found that document: "How to Fix the Start SUT Session Error in CBT"

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/c0ab109a-ce16-3110-6ba5-82cbafc36b2f?QuickLink=index&…

Finally I found it:  the SAPLOGON was buggy; I patched to  SAP Logon for Windows, 740 Final Release,  7400.1.2.1100,  Build 1564922 and now it works.

By the way, how can I close it?!? Set this as correct answer?

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question