Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Root org unit not passed when data element's RFC gets called

I'm creating a second org chart because I need different (complex) filtering.

For that I created a copy of the RFC's and created two new Data Elements.

One for the the org hierarchy and one for the position hierarchy. (Very similar to the original org chart)

After this I create a new Data Element Hierarchy, again nearly identical as the original org chart, but this time using the new data elements that are linked to the custom RFC's.

The ID's and parent ID's in the general settings have been setup and the root org unit has been defined.

Save, publish, nada. "Cannot find the root of your orgchart.".

When I enable the RFC trace I see that all (except the defaulted values) are empty! The root org unit is thus not passed in any of the fields (I believe it should be passed in the ORGUNIT_ID field first to get the info of the root org unit and after that in a new call using the PARENT_ORGUNIT_ID field.

It's not a publishing issue, because I've been having this across builds, published and loaded new builds many times.

There is no difference in the logs between loading up the working original "Organizational Structure" hierarchy and my (nearly identical) custom hierarchy.

Any help is welcome, because I'm out of ideas.

BTW. This is with Nakisa OrgChart 4.0 SP1.

Tags:
Not what you were looking for? View more on this topic or Ask a question