Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Specific users can no longer create tiles in catalogs. Error "Resource PageChipInstance not found" in PAGE_BUILDER_CUST service.

Hi Everyone,

A number of users are having difficulties creating tiles for their new catalogues in Fiori admin and get the following error message below.

However some users like myself do not have this error message and can create tiles for groups without any issue even when we have the same authorisations.


Also if I create a fresh user from scratch in SU01 and copy in the same authorisations - this user does not experience the same problems of adding tiles to catalogues.

/IWFND/ERROR_LOG shows returns the error message "Resource PageChipInstance not found".

I've tried to troubleshoot with the following steps to no avail.

- Checked authorisations were not different.  Authorisations were the same for my user and user experiencing problem.

- Copied the problematic user to another user.  Unable to create tile in catalogue.  Receive same error message.

- Deactivated and reactivated the following SICF services via /IWFND/MAINT_SERVICE

     - INTEROP

     - LAUNCHPAD

     - PAGE_BUILDER_CONF

     - PAGE_BUILDER_CUST

     - PAGE_BUILDER_PERS

- Ran the following ABAP programs in se38.

     /UI2/CHIP_SYNCHRONIZE_CACHE (no short dumps in ST22).  Checked /UI2/CHIP_CHDR for specific errors.

     /UI2/DELETE_CACHE_AFTER_IMP

     /UI2/DELETE_CACHE

- Cleared Metadata Cache

     /IWFND/CACHE_CLEANUP on Gateway

     /IWBEP/CACHE_CLEANUP on Gateway

- Cleared HTTP server cache locally and globally in SMICM.

- Individual users have cleared their browser caches.

I haven't tried deleting and recreating the OData service PAGE_BUILDER_CUST as per this thread but thinking about trying this.

Error while adding tile in launchpage

We are on UI Add-On SP11.

Has anyone encountered this user specific issue before?

Regards,

Ben

Tags:
Former Member
Former Member replied

Hi Guys,

Our very own awesome basis consultant Tim has solved the problem with some great sleuthing work.  Remember this problem affects specific users and is not a problem with the PAGE_BUILDER_CUST service itself.

This issue was caused by a value stored in the parameter tab in su01.  The parameter was /UI2/WD_TRKORR_CUST which contained a reference to a customising transport which had already been released.

What would happen is if you tried to create a tile in the catalog referencing this transport, it would try to save it to the released transport and fail with the above error message.

The solution is to clear this parameter or assign it to a valid transport and you should be good to go.

I hope this solution helps anyone who comes across it.

Thanks.

Regards,

Ben

2 View this answer in context
Not what you were looking for? View more on this topic or Ask a question