Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Work Manager 6.2 Customer Service Assignment Type

SAP & Experts,

Is there an incorrect configuration in the "SAP_CUSTOMER_SERVICE_21" application configuration in the APPLICATION_CONFIG global for the "Wo.AssignmentType"?  Here is why I am thinking this.

I've installed the base Work Manager 6.2 with Customer Service.  I create the application in the cockpit and publish it in.  I even stopped/started the SMP services to make sure it was "clean".

When I try to connect the client the first time, I get this error in the transmit window:

Invalid Wo.AssignmentType from the ini file or SAP mobile configuration. Please check the ini file or the mobile configuration for assignment type () in section APPLICATION_CONFIG

In the Config Panel, I looked at the global configuration for "Wo.AssignmentType" and the "DO_ID" is set to "SCS21_SERVICEORDER_GENERIC".  I then compared this to the previous "SAP_CUSTOMER_SERVICE_20" application's value for this and for that version the "DO_ID" is set to "SCS20_WORKORDER_GENERIC".

I suspect that the 21 version should be "SCS21_WORKORDER_GENERIC"

I believe this is in error in the application configuration panel as delivered by the base package.

If an expert would confirm this is incorrect, and if so, SAP could/should then correct this in an update patch.




After investigation and tracing through the config panel, a couple things have happened here.  First, the underlying issue is that this filter is using a rule.  That rule is requiring a Parameter ID of "/SMERP/PM_WO_DISTMOD" to be set on the user with the vlue of the assignment type.  This makes no sense to put this at the User level since assignment of orders is done one way across the SAP PM platform.

So, the short answer is if you want it to work OOB, you have to set this parameter ID on the user profile.

This then brings up the issue of this not making sense.  For the "base" Work Manager application id (SAP_WORK_MANAGER_62), the assignment type is correctly (in my opinion) still done by just setting it to "1" (or whatever is the appropriate value).  It is ONLY for the Customer Server application (SAP_CUSTOMER_SERVICE_21) that uses this rule.  Again, in my opinion the Assignment Type filter should just use the value and not the rule.  This can easily be done by just unchecking the "Use Rule" checkbox on the Mobile Application's parameters.  But it shouldn't need to be done, it should be delivered this way OOB.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question