Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

B2B Web Channel on NW7.4: Java 1.4 or 1.6

Hi,

According to the blog

https://blog.boris-wach.de/permalink/141

when we create the project in NWDS for development of the Web Channel we should set the Java Version to Java 1.4.

We are running NW7.4 as our server, which is Java 1.6, I believe.

We are using the latest E-Commerce SCA's, which are NW7.3; but isn't NW7.3 also Java 1.4?

Did SAP not update the E-Commerce app to Java 1.6?

Should we really set the Java version to 1.4 in NWDS when we create the B2B project?

I've been playing with this in a sandbox for the last couple of weeks and there I set the Java version to 1.6 and haven't had any problems; but later this week I'll be moving to our real Dev system and setting things up, so I want to make sure that I don't make any mistakes.

Any help is greatly appreciated,

P.

Former Member replied

Patrick O'Niell wrote:

We are running NW7.4 as our server, which is Java 1.6, I believe.

We are using the latest E-Commerce SCA's, which are NW7.3; but isn't NW7.3 also Java 1.4?

Please don´t even think about 1.4  As it looks like you are completely lost in the various documentations you find for specific applications

Here are the facts :

  • NetWeaver 7.0x is always 1.4 Java
  • NetWeaver 7.3x and 7.4x is always 1.6 Java - what runs on 7.3 does also run on 7.4, but 7.3 / 7.4 apps do not run on 7.0 (!!)
  • WCEM does require 7.3x NetWeaver or higher. It was never developed for 7.0x especially as the technologies used lile JSF are not available on 7.0x independent of the Java version itself
  • SAP ISA is available for 7.0x NetWeaver AND for 7.3x/7.4x Java environments - BUT careful, you have to download different SCA files - it is phyiscally not 100% same code as the code was migrated from 7.0x to 7.3x and higher.
  • SAP NWDI can be e.g. 7.3+, but can handle projects (development tracks) for also 7.0x environments (but you have to setup multiple JVMs on the same machine => 1.4 & 1.6)

Because 7.0x enviornments run out of support and Java 1.4 is anyway no more supported by Oracle, you would always go for 7.3x or higher as runtime environment.

The only reason why you wanne stay with 1.4 is because your current clients application is still running on. You need to perform a small migration project to upgrade such application to the NetWeaver 7.3x codebase. This is not so complicated, but you might need some experience doing that - i just recently did that in a few days.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question