Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Sybase ASE - Cannot change parameter to start DB

Hi,

We are facing an issue while trying to start our Sybase ASE database running on Windows 2012. This is after we had to take a reboot of the server and the application/DB were stopped correctly.

The corresponding SQL service Sybase SQLServer_<SID> is not running even after trying manually.

The ASE <SID>.log file has the following information.
----------------------------------------------------
kernel libomni1 - Component Integration Services: using 'Sybase Client-Library/15.7/P-EBF23553 SP132/X64/BUILD1570-046/OPT/Sun Nov 02 11:18:33 2014'

kernel Cannot allocate shared memory as 'max memory' limit of '3398304' pages has been reached. Please increase configuration parameter 'max memory' to allow additional shared memory allocation. Total physical memory allocated so far '3398304' pages.

server  Configuration of the cache (default data cache) failed since the defined cache configuration consumes more memory than is available for buffer caches.

server  Invalid Configuration: Unable to start Adaptive Server. The server may be started with a default configuration using the -c startserver option.

------------------------------------------------------------------------------


Tried starting the DB using -c startserver, but that doesnt work.

Logs:

------------------------------------------------------------------------------
D:\sybase\SED\ASE-15_0\install>RUN_SED.bat -c startserver

D:\sybase\SED\ASE-15_0\install>rem

D:\sybase\SED\ASE-15_0\install>rem Adaptive Server Information:

D:\sybase\SED\ASE-15_0\install>rem  name:                          SED

D:\sybase\SED\ASE-15_0\install>rem  master device:                

D:\sybase\SED\sybsystem\master.dat

D:\sybase\SED\ASE-15_0\install>rem  server page size:              16384

D:\sybase\SED\ASE-15_0\install>rem  master device size:            400

D:\sybase\SED\ASE-15_0\install>rem  errorlog:                     

D:\sybase\SED\ASE-15_0\install\SED.log

D:\sybase\SED\ASE-15_0\install>rem  interfaces:                    D:\sybase\SED\ini

D:\sybase\SED\ASE-15_0\install>rem

D:\sybase\SED\ASE-15_0\install>"D:\sybase\SED\ASE-15_0\bin\sqlsrvr.exe" -d"D:\sy

base\SED\sybsystem\master.dat" -sSED -e"D:\sybase\SED\ASE-15_0\install\SED.log"

-i"D:\sybase\SED\ini" -M"D:\sybase\SED\ASE-15_0"

00:0000:00000:00000:2015/01/14 12:36:15.92 kernel  kcinit: couldn't open error l

og file 1'D:\sybase\SED\ASE-15_0\install\SED.log'.

00:0000:00000:00000:2015/01/14 12:36:15.92 kernel  Failed to log the current mes

sage in the Windows NT event log
------------------------------------------------------------------------------

The problem is that since database is down, we cannot login to isql to change the parameters. We even tried modifying the <SID>.cfg file manually  and restarting DB to update the parameter, but didn't help. The <SID>.log file is not updated after restart.

How to change the database parameter when sybase database is down? Any other way to start the database?

The problem is similar to the one mentioned in the following thread:

http://scn.sap.com/thread/3633956

Would appreciate your inputs.

Regards,

Varun

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question