Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

'Include....001' not found by SAP main program after transport

Hi all,

I have developed a workflow application for our inhouse administration. During the workflow development, the workflow Builder (I suppose so) has created some screens and PBO/PAI modules, which it has placed into a function pool named 'SAPLZWS91200013' (according to the workflow ID).

I have transported all the staff from the Dev. system to our test system, and have got the following error message:

>>> Program SAPLZWS91200013: Syntax error in line 000015

>>> INCLUDE report 'ZWS912000130001' not found

So it seems, that the main program does not recognize the Include, although present in the respective folder.

In more detail: The 'Main program' (of the function pool) SAPLZWS91200013 is:

1*******************************************************************

2*   System-defined Include-files.                                 *

3*******************************************************************

4  include lzws91200013top.                   " Global Data

5  include lzws91200013uxx.                   " Function Modules6

6

7*******************************************************************

8*   User-defined Include-files (if necessary).                    *

9*******************************************************************

10* INCLUDE LZWS91200013F...                   " Subroutines

11* INCLUDE LZWS91200013O...                   " PBO-Modules

12* INCLUDE LZWS91200013I...                   " PAI-Modules

13* INCLUDE LZWS91200013E...                   " Events

14* INCLUDE LZWS91200013P...                   " Local class implement.

15  include zws912000130001.

16  include zws912000130002.

17  include zws912000130003.

18  include zws912000130004.

19  include zws912000130005.

20  include zws912000130006.

21  include zws912000130007.

The Folder 'Includes' of that function pool really contains that routine 'zws912000130001', so I have no idea, why the main program does not recognise it. Even when I have re-opened, syntax-checked and activated that function pool again, after an additional transport it shows the same error.

Thanks for any comments and ideas,  Regards Johann

Former Member
Former Member replied

Thank you all,

I have transported the objects individually and it worked.

Many Thanks    Johann

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question