Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Upgrading Sybase IQ 16 SP01 to SP04

Dear Sybase Gurus,

I am very new to Sybase IQ. We want to Upgrade Sybase IQ 16.0 SP01 to SP04. Could you please guide me on this, i have found many documents but i am confused a abit.

Server : Windows Server 2008 R2 Enterprise

Best Regards

Former Member replied

Hi

Please refer to below Readme File of SP04 on Windows.

===================================================

   I. Upgrading the Current SAP IQ Version

   ------------------------------------------

   If you have already installed SAP IQ, before installing this update,

   enter the following command to verify that you are using the correct

   version of SAP IQ:

  

      > %IQDIR16%\bin64\start_iq -v2

   

   The server should return a version string similar to the following:

  

      Sybase IQ/16.0.0.481/130503/P/sp01/MS/Windows 2003/64bit/2013-05-03 17:19:35

   II. Backup Notes

   ----------------

  

   * Database Backup Notes

  

   Back up your databases before installing this support package. SAP

   strongly recommends backing up your database before performing any

   installation or upgrade.

   * Software Backup Notes

  

   This upgrade will require uninstalling the current version of SAP IQ.

   Make sure that any non-default or user created files in the IQ directory

   (%IQDIR16%) are safely backed up before beginning.

  

   III. Installation and Upgrade

   -----------------------------

   * O/S Requirements

   The windows installer requires Microsoft Visual C++ 2005 SP1

   Redistributable Package. If you get this error:

      Windows error 14001 occurred while loading the Java VM

   Install the Microsoft Visual C++ 2005 Service Pack 1 Redistributable

   Package MFC Security Update before launching the installer again. The

   SAP support package is included as part of the install package.

   To install:

      - Open Windows Explorer.

      - Navigate to \archives\ms-redist-2005 in installable image

      - Run vcredist_x86.exe (for 32-bit) and vcredist_x64.exe (for 64-bit)

   The Redistributable Package is also available at the Microsoft Download

   Center at: http://www.microsoft.com/en-us/download/details.aspx?id=26347

   Before installing this software, check the patch levels of the target

   system. See the SAP IQ 16.0 Release Bulletin for minimum O/S

   requirements for this support package. SAP recommends that you keep

   your system current with the latest patches.

   * Preserving Modified Default Values

  

   For each database, run sp_iqcheckoptions and capture the output before

   and after the upgrade. The sp_iqcheckoptions procedure lists current

   and default values of database and server startup options that have been

   changed from the default. The procedure output shows if any default

   values that you reset have changed in the new release, and records the

   values being used, so you can reset them after the upgrade.

  

   * Shutdown Sybase Control Center

   If Sybase Control Center is currently installed and running it needs

   to be shutdown before installing SAP IQ.

   - If Sybase Control Center is running as a Windows Service, use the

     Services list under the Windows Control Panel to stop the Sybase

     Control Center service.

   - If Sybase Control Center is running from the command line run the

     %SYBASE%\SCC-3_2\bin\scc.bat -stop command

   * License Validation

  

   The SAP IQ installer includes a step to verify that your license

   maintenance support is in compliance (or near compliance).  A server

   that is more than 1 year out of maintenance will not run. Validating your

   license(s) before you install this update ensures that your database

   functions correctly after installation. A validation should be done

   for each database on which this update will be applied.

   The installer includes an 'unknown' product edition and 'unknown' license

   type options. SAP includes these options to accommodate potential

   problems in the license file where the product edition or license type

   may not be valid. If you see this, please verify your license's content

   and location.

   * Installation

  

   You can install this software only as a standalone install. The 16.0

   GA software is not required as a prerequisite for the standalone install.

   * Upgrade Instructions

  

     This release of SAP IQ 16.0 SP4 does not support rolling

     upgrades.

   * Upgrading Simplex

   1. Shut down all affected SAP IQ servers.

      See See "Stopping Servers" in the SAP IQ Installation and Configuration

      Guide.

   2. Back up the databases and any modified files in the

      %IQDIR16% directory.

   3. Uninstall the current version of SAP IQ. See the SAP IQ

      Installation and Configuration Guide for the uninstall process.

   4. Install this update.

   5. Verify that this support package has been installed correctly by

      checking the version string of the server: start_iq -v2

   6. Start the server and run ALTER DATABASE UPGRADE

   * Upgrading Multiplex

   1. Shut down the multiplex node. See "Stopping Servers" in the SAP IQ

      Installation and Configuration Guide.

   2. Back up the databases and any modified files in the

      %IQDIR16% directory.

   3. Uninstall the current version of SAP IQ. See the SAP IQ

      Installation and Configuration Guide for the uninstall process.

   4. Install this update.

   5. Verify that this support package  has been installed correctly by

      checking the version string of the server: start_iq -v2

   6. Restart the multiplex coordinator. Connect to the coordinator and

      run ALTER DATABASE UPGRADE. Synchronize the multiplex secondary 

      nodes. See "Synchronizing Servers" in the Administration Guide.

===================================================

Thanks

Gi-Sung Jang

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question