Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Relapse on SDA/Oracle

Hi all,

Firstly after my last "adventure" with SDA where I made a highly fundamental error, we managed to have some great success with SDA.  We connected to Oracle, Hadoop and MS/SQL.  In the case of Oracle we managed to almost seamlessly creqte HANA definitions by using Oracle Meta Data via Data Pump creating pluggable databases in out lab, then creating virtual HANA tables  and finally creating actual HANA tables.  The advantage of this is that we can now ensure correct domain translation.

OK, so I know that I actually owed the forum a "blog" on the above, but (and I seem to live my life in embarrassment ) but I actually "lost" my original machine (VM) and have now started to deploy an SDA setup (on both an 82 and an 84 HANA) again.  Once again I am using the manuala anf Leo Hue's excellent article.

So the embarrasment is that I have installed the ODBC  and the instantclient software but for some reason, the ldd produces the following (I have dome the isql --version successfully):

linux-gate.so.1 =>  (0xffffe000)

libdl.so.2 => /lib/libdl.so.2 (0xf75c6000)

libm.so.6 => /lib/libm.so.6 (0xf759d000)

libpthread.so.0 => /lib/libpthread.so.0 (0xf7582000)

libnsl.so.1 => /lib/libnsl.so.1 (0xf7568000)

librt.so.1 => /lib/librt.so.1 (0xf755e000)

libclntsh.so.12.1 => /root/instantclient_12_1/libclntsh.so.12.1 (0xf51c9000)

libodbcinst.so.2 => not found

libc.so.6 => /lib/libc.so.6 (0xf502a000)

/lib/ld-linux.so.2 (0xf7774000)

libnnz12.so => /root/instantclient_12_1/libnnz12.so (0xf4bd2000)

libons.so => /root/instantclient_12_1/libons.so (0xf4b9e000)

libaio.so.1 => /lib/libaio.so.1 (0xf4b9b000)

libclntshcore.so.12.1 => /root/instantclient_12_1/libclntshcore.so.12.1 (0xf4932000)

So the problem is with libodbcinst.so.2 . The module is definitely there (installed in /usr/ocal/lib) and the library in the LD_LIBRARY_PATH and implemented via hdbenv.sh

I think that my problrm is that last time I had done so much to "fix" my eventually silly error that I it was not obvious this time.  The permissions all look OK, but any help as usual appreciated and (the promise of s desperate man!) if I get out of this I promise to share more .

Regards

John

Tags:
Former Member
Former Member replied

Sorry for not closing this, but after fixing the driver, I started with another issue which I thought would be interesting to document and of course also see is anyone has any ideas.

To recap, the essence of the exercise is to create HANA tables which are replicas of Oracle tables (several hundred).  I do this by hooking into Oracle 12c Pluggable databases to create remote sources,  creating virtual tables in HANA studio and then generating "CREATE LIKE" DDL to create the HANA tables.

Once again, I hit the ubiquitous when testing the created remote source:

SAP DBTech JDBC: [403]: internal error: Cannot get remote source objects: [SAP][ODBC Driver Manager] Unable to load driver /usr/sap/L01/instantclient_12_1/libsqora.so.12.

While being prone to silly mistakes throughout the exercise, I did make sure that everything was properly in place (thanks once again Leo Hui).

To cut a long story short, while pulling my hair out, I switched from HANA Studio on Windows (91) to HANA Studio on UBUNTU (85) - which is what I had been using when first played around with SDA- , and it worked!  I could then access and test the new Remote source from the Windows HANA Studio i.e. it had been created using the UBUNTU one and the used on the Windows one.

As an aside, we have also implemented replication going through a second network.  The actual repication has been switched off but for some reason, in the index server alert log I see the following:

[5024]{200728}[51/-1] 2015-01-16 07:47:49.988387 e TNS              TNSClient.cpp(00800) : sendRequest dr_getremotereplicationinfo to 192.168.200.28:30102 failed with NetException. data=(I)drsender=1|


[5024]{200728}[51/-1] 2015-01-16 07:47:49.997525 e TNS              TNSClient.cpp(00800) : sendRequest dr_getremotereplicationinfo to 192.168.200.28:30001 failed with NetException. data=(I)drsender=1|


[5024]{200728}[51/-1] 2015-01-16 07:47:49.997573 e sr_nameserver    TNSClient.cpp(06787) : error when sending request 'dr_getremotereplicationinfo' to 192.168.200.28:30102: connection refused,location=192.168.200.28:30001

Note that 192.168.200.28 is not the ip address of the "application" side of the server but that for replication.  This of course may be a red herring, but I thought that I would mention it.

In any case, sorry for being so verbose, but any ideas are welcome.  Moderator (and I know that I have lied before ) will keep this open for a few days.

So the HANA journey continues.

Regards

John

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question