Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

When running from DMP can't read parameters from Badi

Dear experts,

I'm new to BPC. I'm using BPC 10 NW. I've implemented a new Badi for UJ_CUSTOM_LOGIC. This Badi is executed from Data Manager in a package.

I have an issue when reading parameters from IT_PARAM internal table within the Badi.

Script that runs from a package in Data Manager:

Abap code that read the parameters table it_param (it comes through the interface in method execute):

As you can see is a simple read table.

Issue:

If I run it from DM this above read fails (sy-subrc=4) and can't read my parameters.

But if I run it from UJKT it executes fine (sy-subrc=0) and reads my parameters ok.

UJKT run:

DM run:

I can't figure out why it behaves differently?

It's not to do with the read statement as it works fine from UJKT.

Am I missing something from DM side? May be some permissions?

Anybody experienced this ever? Any clues?

Thanks and regards,

Laura

Former Member
replied

dm doesn't put space normally maybe the consultant who wrote the SL wrongly put extra spaces or any other problem.

Because, the UJKT script logic is given by BPC consultant i think, and you don't have access to BPC Web Admin i assume ? is it like that ?

So best way is, just do a loop-endloop and check all the parameters one by one with HASHVALUE and HASHKEY in LWA_PARAM .

Or give me remote access i check coz i also get crazy it is not possible.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question