Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

TypeError: sap.ui.app is undefined

Hello Community,

based on the blog post Developing a simple List based SAPUI5 Application I am trying to create an SAP UI 5 application. But I am facing the below error and the application fails to load.

Can anybody help me with this Error?

Thanks!

Tags:
Former Member
replied

Hmmm, ok... I guess it has something to do with the deprecated Application class, which has been replaced by the Component.js

Probably the sap.ui.app library now does not exist anymore... But as a test, could you then try and *add* the sap.ui.app library to the bootstrapper? Maybe it works...

However, a better solution would be if you could refactor your application so it uses the Component.js class instead of the Application.js. See also the best-practices guide at SAPUI5 SDK - Demo Kit

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question