Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

No connect due to DbSl Load Lib Failure


Hi All.

I've just installed a new Solution Manager 7.1 w\Sybase DB system. I've upgraded my kernel to 7.21ext v300 (I've also tried v400).

I've applied the latest TP and R3trans (as well as tried older ones)

I am currently using the latest SUM to patch my system to stack 12. It is failing with:

ERROR: No connect due to DbSl Load Lib Failure

ERROR: Possible reasons are:

ERROR:  - The value set for dbms_type ('syb') is invalid.

ERROR:  - Cannot find the DLL dbsybslib.dll in path

ERROR:  - problems when loading DB-dependent DLLs

ERROR: Connect to SM1 failed (20150107181705).

SAPup> Process with PID 6412 terminated with status 249 at 20150107181705!

The value 'syb' is correct because I am using a Sybase database.

I checked, and dbsybslib.dll is in both;

D:\usr\sap\SM1\SYS\exe\uc\NTAMD64

and

D:\usr\sap\SM1\DVEBMGS00\exe

Not sure how to check for 'ERROR:  - problems when loading DB-dependent DLLs'

My PATH reads:

C:\Users\sm1adm.FORTCHICAGO>path

PATH=C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windo

ws\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\SQ

L Anywhere 16\bin64;C:\Program Files\SQL Anywhere 16\bin32;D:\usr\sap\SM1\SYS\ex

e\uc\NTAMD64;\\VERQSM\sapmnt\SM1\SYS\global\syb\NTAMD64\sybodbc;D:\sybase\SM1\OC

S-15_0\bin;D:\sybase\SM1\OCS-15_0\dll;D:\sybase\SM1\OCS-15_0\lib3p64;D:\sybase\S

M1\OCS-15_0\lib3p;D:\sybase\SM1\ASE-15_0\bin;D:\sybase\SM1\ASE-15_0\dll;D:\sybas

e\SM1\ASE-15_0\jobscheduler\bin

And R3trans -d reads:

This is r3trans version 6.24 (release 721 - 08.05.14 - 16:50:00).

unicode enabled version

R3trans=>sapparam(1c): No Profile used.

R3trans=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

r3trans finished (0000).

Any ideas would be appreciated.

Thanks,

Diana

Former Member
Not what you were looking for? View more on this topic or Ask a question