Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Having runtime issues with CRVS2010 on Server 2012 r2 Deployment, I must be missing something

I have developed a .Net 4.0 Web Service that uses Crystal Reports 13 SP12 redistributable runtime to return reports rendered as HTML to callers of the service.  The Web Service is hosted in IIS 8.5 on Windows Server 2012 r2.  Report source files are developed in SAP Crystal Reports 2013.

Report parameters are passed in the service calls to the Web Service on the server where the *.rpt files are also hosted.  The service uses the CR libraries to open the rpt file and set appropriate DB connection info, and parameters values, then generates the report to a temp folder accessible by the service, then integrates html and image into a single html response to the caller.

I understand that Crystal is using other temporary folder locations for internal processing when generating (exporting) a report, I can see this in ProcMon on the server when the service call is made.  My problem is that no report is generated though I see tracing in Procmon that indicates a temp file is created in the temp folder, but I never physically get the file to process and return in the service call. 

I think I've got the right runtime, platform, and report editor based on information here, http://scn.sap.com/community/crystal-reports-for-visual-studio/blog/2013/06/28/how-do-you-spell-confussion-cr-for-vs-crystal-2011-bi-4x-and-the-net-sdks, but perhaps not.

The Web Service with corresponding Crystal Reports 13 SP12 runtime redistributable works perfectly on Windows Server 2008 r2.  We are deploying both CR10.5 and CR 13 SP12.

These are the assembly references in the Web Service project:

CrystalDecisions.CrystalReports.Engine

CrystalDecisions.ReportSource

CrystalDecisions.Shared

CrystalDecisions.Web


Tags:
Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question