Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Debugging duplicate records from PSA into WO DSO

I am doing some testing and the code i didn't change (I think) is giving me problems. Joy ...

There is a delta extractor loading the PSA table 0CO_OM_CCA_9. I ran an extraction on Monday and 0 records came across. Our tester put 2 records into ECC Tuesday morning. Here is his email:

    As requested, I have put some data into U10 to test the QB1 2015 cubes.

    SAP Doc # 7153797919 - January 2015

    There are 2 postings in company code 1000:

    4259001 DG1174 $5,000,000

    4218001 DG1174 $1,000,000

    Offset for both is 7008151

I ran the extract within 20 minutes of his note and  no records came across. I ran it again a couple hours later and received 6 records.

I then ran a DTP delta from the PSA to a WO DSO. It fails claiming the first 3 records are duplicates. When I look at the data in the DTP's extraction step (from the process monitor) I see the records in the attached spreadsheet.

The semantic key for our DSO is

  • 0CO_AREA
  • 0CO_DOC_NO
  • 0CO_ITEM_NO
  • 0CURTYPE
  • 0METYPE
  • 0VTYPE
  • 0FISCVARNT

When I query the DSO before hand for anything in period 2015.001 for cost center DG1174 I get no records found.

After I run the DTP (with the noted error), I see the 3 records for account 4218001 (the $1M record), but not the 3 that the DTP is complaining about.

Looking at the spreadsheet, I cannot see what might be the duplicate key it is complaining about.

In the PSA maintenance screen, only the last extraction (with the 6 records) exists - I have deleted all the rest.

Tags:
Not what you were looking for? View more on this topic or Ask a question