Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Deletion of authorization object fails

Hi Experts

I am trying to delete a a Authorization object through SU21, but it fails and tells me it can not be deleted because it still contains authorizations. After that it shows me the authorizations name.

So i want to delete the authorization first, but i can't find anywhere to delete it.

I have deleted all roles and profiles with that name, but still no luck.

I can see in table USR12 that there exists a combination of the authorization object and the authorization blocking the deletion.

Could someone tell me where to go to delete such an object.

Or could this be some kind of mistake in a table and is there then a way to fix it?

I am running a BW 7.31 system, but i guess this is part of the general SAP authorization setup.

Thanks in advance.

Former Member
replied

Have you tried if PFUD cleanup will clear out entries in those tables?

I included a diagram here that shows the connection between key security tables - might help you understand the dependencies

Re-generating derived roles shows changes

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question