Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Set SAPJVM startup parameter

Hello All,

I am having JVM outofmemory error & check some SAP notes , They are saying below:

The parallel / concurrent collector will throw an OutOfMemoryError if too much time is being spent in garbage collection: if more than 98%

of the total time is spent in garbage collection and less than 2% of the heap is recovered, an OutOfMemoryError will be thrown. This

feature is designed to prevent applications from running for an extended period of time while making little or no progress because the

heap is too small. If necessary, this feature can be disabled by adding the option -XX:-UseGCOverheadLimit to the command line.

---------------------

You can try to disable this default policy by simply adding this

parameter at your JVM start-up:

-XX:-UseGCOverheadLimit

But if i try to use below:

java -XX:-UseGCOverheadLimit , It is giving me error. & not taking that option.

So where should i set that parameter ? How i can i add this parameter to JVM start-up?

Please help.

Former Member
Not what you were looking for? View more on this topic or Ask a question