Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Activate .xsapp: Unsupported encoding Cp1252, only UTF-8 encoding is supported

Hi,

I'm new to HANA/XS. I'm trying to create a test Hana application. I have eclipse luna 4.4.1 installed. I have installed Hana plugin from https://tools.hana.ondemand.com/luna (screen shot below):

I have connected to a HANA system, created repository, packages etc. Basically all the necessary things to create a test HANA XS project.

But, when I create .xsapp and .xsaccess I get the following error whenever I try to activate those files:

Unsupported encoding Cp1252, only UTF-8 encoding is supported

Am I missing something? I tried finding similar error in the forum, but I was not successful. Kindly try to help me.

Thanks & Regards,

Lohit

Tags:
Former Member
Former Member replied

Hi Lohit,

I had the same problem. Change the default encoding in Eclipse to UTF-8 (window -> prefecences -> general -> workspace) and then delete the project from Eclipse. Then check it back out from the HANA repository. This worked for me.

Regards,

Gert

14 View this answer in context
Not what you were looking for? View more on this topic or Ask a question