Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Crystal Report Parameters Window shows Technical Name of Parameter Object

Hi

I am using SAP Crystal Report 2013. There is a report which has about 5 sub reports. The Main Report has the following run time parameters:

1. Enter Username

2. Enter Start Date

3. Enter End Date

The User Name is based on the Client code (ClientTable.ClientCode)

The Start Date is based on Invoice Date Start (InvoiceTable.InvoiceDate)

The End Date is based on Invoice Date End (InvoiceTable.InvoiceDate)

One of the sub Reports also has similar parameters as follows:

1. Enter Username

2. Enter Start Date

3. Enter End Date

4. Enter Passenger Name

The User Name is based on the Client code (ClientTable.ClientCode) within the sub report

The Start Date is based on Invoice Date Start (InvoiceTable.InvoiceDate) within the sub report

The End Date is based on Invoice Date End (InvoiceTable.InvoiceDate)  within the sub report

The Passenger Name is based on the Passenger Name in Invoice Table (InvoiceTable.PassengerName) within the sub report.

During run time, these prompts (Paramters) merge and ask for following paramters from the user which is perfectly fine:

1. Enter Username

2. Enter Start Date

3. Enter End Date

4. Enter Passenger Name

But along with the parameter names, the technical description also comes on the right side of each parameter. For example

1. Enter UserName:                    ClientCode/ClientCode(subreport)

2. Enter Start Date:                     Date1/Date1(subreport)

3. Enter End Date:                      Date2/Date2 (Subreport)

4. Enter Passenger Name:        PassengerName

Is there a way to hide the Technical description that appears on the right side? Please see attached screenshot.

I tried the following and it didn't work:

Under Infoview preferences--> Crystal Reports --> , I unchecked the "Show SAP Variable Technical Name (SAP Crystal Reports 2013 only)".

Thanks

Dhivya

Tags:
Former Member
replied

Hi Dhivya,

Login to BI Launchpad  > Preferences > Crystal Reports

Then Uncheck the Option "Show SAP Variable Names"

--Praveen G

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question