Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

PI and CRM connectivity

HI Experts,

I want to test the connectivity between PI and SAP CRM system
.

Below are steps I followed:

1)Created ICO in PI and XI receiver channel(XI 3.0) Target URL: http://CRMHOST:8000/sap/XI/engine?type=entry with user authentication(USER with SAP_ALL )

2)Created and tested successfully destinations type G SAP_PROXY_ESR and PI_AAE in SM59of CRM system.

3)Created and tested successfully destinations type  T SAPSLDAPI in CRM system with Registered Server Program defined in NWA JCO (Program ID is running fine in JCO) and Gateway host and service of CRM system.

4)Activated all services in SICF.

5)Created 2 parameters as below: in INtergration Engine Configuration in SXMB_ADMof CRM system

RUNTIME ENGINE_TYPE LOC

RUNTIME IS_URL dest://PI_AAE

6)SLDCHECK and SLDAPICUST working fine.

But I am getting error in XI Receiver channel "BubbleException: HTTP Response Received.Status Code = 500[null "null']'

2 questions:

1)have I missed any configurations/setting?

2)Proxy is not generated yet in CRM system, is it necessary that proxy should be generated and activated in CRM system than only messages will flow from PI?

Waiting for your valuable inputs.

Regards,

SarVjeet

Former Member
Former Member replied

Hi all,

Once I have generated and activated the proxy objects(data type , message type and service interface) in CRM system.

All working as expected , PI is able to send messages to CRM and I can see these messages in sxmb_moni of CRM system.

Closing the thread.

Regards,

Sarvjeet

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question