Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Standard Toolbar ICON not displaying in ALV.

Hi,

I have created a ALV list display. For that i have created a status with Application toolbar and Standard tool bar icons. ...but in my output is only displaying only APPLICATION TOOLBAR icons not the STANDARD TOOL BAR ICONS(SAVE, BACK, EXIT).

My code ll b like this...

CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'

   EXPORTING

     i_callback_program                = sy-repid       " report id

     i_callback_pf_status_set          = 'PF'           " for PF-STATUS

     i_callback_user_command           = 'USER_COMMAND' " for User-Command

     it_fieldcat                       = it_field       " field catalog

   TABLES

     t_outtab                          = it_final      " internal table

   EXCEPTIONS

     program_error                     = 1

     OTHERS                            = 2.

IF sy-subrc <> 0.

    MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno

            WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4.

  ENDIF.

*&---------------------------------------------------------------------*

*&      Form  pf

*&---------------------------------------------------------------------*

*       SUB-ROUTINE PF IS USED TO SET THE PF-STATUS OF THE SCREEN

*       ON WHICH THE ALV GRID IS DISPLAYED

*----------------------------------------------------------------------*

*       -->RT_EXTAB

*----------------------------------------------------------------------*

FORM pf USING rt_extab TYPE slis_t_extab.

  SET PF-STATUS 'ZPF_STAT'.

ENDFORM.                    "pf

Note : In SE41....I have Activated the contents by allocating standard toolbar icons init.

Former Member
Former Member replied

Hi Bharani,

Copy the pf-status STANDARD from program SAPLSALV (main program of SALV) to your program. It will work.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question