Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Please do not enter data for payment method Cheque papel error in IT0009

Hi Experts,

Whenever i try to  maintain bank details infotype for payment type C(Check Papel),the  system is throwing error "Please do not enter data for payment method Cheque papel". As per SAP std, I had deleted the entries for bank key, bank account and bank control key and maintained IBAN field in IT0009.While saving i am getting the error""Please do not enter data for payment method Cheque papel" and I couldn't save the record.

Then i  deleted the entries for bank key, bank account and bank control key and IBAN field also in IT0009. While saving i am getting the error "Fill in all required entry fields". System behaves  as if Iban a required field in IT0009. Our bank details infotype is country specific.We made it country

specific through feature P0009 and setting in table T588M.As per our conf setting IBAN field is optional. Even though IBAN field is optional, this field behaves  as that of a mandatory field in IT0009.Iam  facing this issues only for a few countries like Spain,Italy etc.For other counties i am able to change of create Bank details record  for payment type C.

I have checked in Payment Methods by Country in FBZP (Payment Method Classification is set to Check and BANK DETAILS box is unchecked) but still no solution. Do i need to check in any other setting.

Please shed some light on this issue.Thanks in Advance.

Former Member
Former Member replied

Hi Jobish,

I was also receiving the same error and tried the workaround and the issue got resovled.

Did you try the workaround? The workaround involves making small minor changes to the table / PA30 and again reverting the changes to original. The issue does get resolved.

Can you please try the steps which I shared with you - It's just not about checking, but making the changes on tables (kind of refreshing) and then reverting those changes. It's weird but does work.

Tcode FBZP - > payment methods by country - > select payment method as 'C' and make below changes (make a note of these changes as you will have to undo them after saving the table):

a. Payment method by classification - select bank transfer

b. Reqd master record specifications - check the bank details options and select the options which you want to be entered (a/c no required, IBAN rqd, SWIFT code rqd)

Save the table.

PA30- > Edit any record once again and save it.

Again go to FBZP and undo the above changes, i.e, revert to the original entries and again save the table.

Try editing the record now in PA30 and it allows to save. This is the second weird workaround that I have come across and still not sure why

Please let me know if it still does not work.

Regards

Neha

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question