Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Async interface is executing as Sync

Hi everyone!

I'm with a problem here, I've developed an Async SOAP x Proxy interface.

The Interface is not complex, the both Services Interfaces (in and out) in ESB were configured as Async. The Sender SOAP is configured as "Exactly Once", and thats it.


But when I run a test through SOAPUI, the interface is being executed as a Sync! When I look in SXI_MONI, the QoS that it shows is BE (best effort).

And then a Mapping Error happens .. but it is caused because a Response messaging is being fired.

I tried to refresh the cache, did the scenario again, and nothing.

Does anyone knows what I'm doing wrong?

Thks!

Former Member
replied

Change the soap address location. I don't think that uses your sender channel as it hits integration engine.

use either of the below url's.

You have configured the SOAP sender adapter. You can trigger a call to the sender SOAP adapter using either of the following URLs. However, SAP recommends you to use the second option.

  • http:// <host name> : <port name> /XISOAPAdapter/MessageServlet?channel=<party name> : <service name> : <channel name> . If you have not created a party, enterchannel=: <service name> : <channel name>

  • http:// <host name> : <port name> /XISOAPAdapter/MessageServlet?senderParty=<name of the sender party> &senderService= <name of the sender service>&interface= <name of the interface> &receiverParty= <name of the receiver party> &receiverService= <name of the receiver service> &interfaceNamespace=<name of the interface namespace>

If you want to make use of the url in your wsdl then add "&QualityOfService=ExactlyOnce" at the end as by default it is "Best Effort"

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question